Minecraft Patching
Incident Report for Badlion
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 23:52 UTC
Investigating
Client Updating & Patching System
Posted Nov 06, 2024 - 23:50 UTC
This incident affected: Infrastructure (Minecraft Patching).