Minecraft Patching
Incident Report for
Badlion
Resolved
This incident has been resolved.
Posted
Feb
01
,
2025
-
00:06
UTC
Investigating
Client Updating & Patching System
Posted
Feb
01
,
2025
-
00:04
UTC
This incident affected: Infrastructure (Minecraft Patching).
×
Subscribe to Incident
Subscribe to updates for
Minecraft Patching
via . You'll receive .